Polygon Mainnet – Archive Node Degraded Performance

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted May 27, 2026 - 18:14 UTC

Monitoring

We have brought additional nodes online and are monitoring the situation. Performance is improving, though we have not yet reached full capacity. We will continue to provide updates as the situation develops.
Posted May 27, 2026 - 14:54 UTC

Investigating

The QuickNode team is investigating the degraded performance of Polygon Mainnet (Matic) archive nodes - we will update this page as we acquire new information.
Posted May 27, 2026 - 13:35 UTC
This incident affected: Polygon (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Webhooks, Mainnet — Streams).