Polygon Mainnet Archive RPC Degraded Performance

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 23:15 UTC

Monitoring

Polygon Archive nodes have recovered fully, and 503s have resolved. We are monitoring performance to ensure stability and will provide an update within 10 minutes upon confirmation or if further action is required.
Posted Jan 20, 2026 - 21:14 UTC

Investigating

We are investigating intermittent 503 errors affecting Polygon (Matic) Mainnet Archive RPC, primarily observed in the FRA region. Some customers may experience temporary request failures or degraded performance.

Our team is actively working to mitigate the issue and restore full service stability. Other regions remain unaffected at this time.

We will provide an update as more information becomes available.
Posted Jan 20, 2026 - 20:04 UTC
This incident affected: Polygon (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Webhooks, Mainnet — Streams).