Story mainnet : Block height stalled at 20,818,218

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Aug 10, 2026 - 19:00 UTC

Monitoring

A fix has been implemented for the Story mainnet block height stall at block 20,818,218, and we are monitoring the results. We will provide another update once we confirm the network is stable.
Posted Aug 10, 2026 - 18:48 UTC

Investigating

We are currently investigating an issue where Story mainnet has stalled at block height 20,818,218. We'll provide an update as soon as we have more information.
Posted Aug 10, 2026 - 12:12 UTC
This incident affected: Story (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Streams, Mainnet — Webhooks).