Stuck Network Hemi Mainnet at block 2,083,724

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 23:50 UTC

Investigating

Our Hemi Mainnet nodes appear to have stalled at block 2,083,724 - The QuickNode team is investigating with the Hemi chain team and will update with more information once it is available.
Posted Jun 25, 2025 - 18:33 UTC
This incident affected: Hemi (Hemi Mainnet - JSON RPC API, Hemi Mainnet - Websockets API).