Unichain Sepolia : Node height stalled at 21818269

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Jun 01, 2025 - 01:55 UTC

Monitoring

Network Operational - The incident was caused by a block fork at block 21813748 resulting in hash mismatches. Several nodes have been recovered and the network is now operational, though capacity remains limited as some nodes are still recovering. We continue to monitor the recovery process.
Posted May 31, 2025 - 12:49 UTC

Identified

This height stall seems like a chain-wide issue, and our engineers are closely listening to updates from the foundation.
Posted May 31, 2025 - 06:26 UTC

Investigating

We are currently investigating this issue.
Posted May 31, 2025 - 06:00 UTC
This incident affected: Unichain (Beta) (Sepolia — JSON-RPC API, Sepolia – Websockets API).