Injective Testnet Network Stalled at Block 126627399

Incident Report for Quicknode

Resolved

The Injective Testnet network has resumed producing blocks. Our nodes have reconnected to peers and are advancing normally. This incident has been resolved.
Posted May 21, 2026 - 15:48 UTC

Investigating

The Injective Testnet network appears to have stalled at block 126627399 following a network upgrade — The Quicknode team is investigating and will update with more information once it is available.
Posted May 21, 2026 - 14:59 UTC
This incident affected: Injective (Testnet Tendermint JSON-RPC/REST API, Testnet Cosmos gRPC & REST API, Testnet — Streams, Testnet — Webhooks).