Degraded Performance - Streams, Webhooks, KV Store, REST APIs, Dashboard

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 00:12 UTC

Monitoring

All impacted services have been restored. We are monitoring performance to ensure stability and will provide an update upon confirmation or if further action is required within 10 minutes.
Posted Mar 18, 2026 - 00:01 UTC

Update

Our team has implemented a fix to recover the faucet service. We will continue to monitor performance across all services at this time. We will provide another update by 00:30 UTC.
Posted Mar 17, 2026 - 23:21 UTC

Update

Our engineering team is actively implementing a fix to recover the faucet page. We will provide another update by 23:30 UTC.
Posted Mar 17, 2026 - 22:39 UTC

Update

Most services have fully recovered or in the process of recovering. The faucet is still unavailable to customers. We will provide another update by 22:30 UTC.
Posted Mar 17, 2026 - 21:30 UTC

Update

Our team is continuing work on restoring impacted services. The following services have been restored:
- Streams REST API
- Webhooks REST API
- Customer Dashboard
- KV Store REST API
- Solana Priority Fee API
- SingleFlight Marketplace AddOn APIs

We are actively monitoring for stability and we will provide another update regarding remaining impacted services by 21:20 UTC.
Posted Mar 17, 2026 - 20:56 UTC

Update

Our team is continuing work on restoring impacted services. The following services have been restored:
- Customer Dashboard
- KV Store REST API
- Solana Priority Fee API
- SingleFlight Marketplace AddOn APIs

We will provide another update regarding remaining impacted services by 21:30 UTC.
Posted Mar 17, 2026 - 20:38 UTC

Identified

Our team has identified the issue and we're currently working on restoring services. Currently, the Dashboard, Solana Priority Fee API, and KV REST API have been restored and we are continuing to monitor and resolve impacted services.

We will provide an update by 20:30 UTC.
Posted Mar 17, 2026 - 20:02 UTC

Investigating

We are investigating issues impacting REST APIs including Streams, Webhooks, and KV Store. Users may also have issues accessing their Dashboard page. We will provide updates once we have more information.
Posted Mar 17, 2026 - 19:11 UTC
This incident affected: Quicknode Products (Quicknode Faucet, Marketplace: Single Flight RPC, Quicknode Streams, Quicknode Functions, Quicknode Webhooks) and QuickNode Dashboard.