Cyber Mainnet - Network Stall

Incident Report for Quicknode

Resolved

The issue affecting Cyber mainnet has been resolved. The network has resumed producing blocks and is operating normally.
All Cyber mainnet RPC endpoints are now fully operational. If you continue to experience any issues, please contact our support team.
Posted Mar 11, 2026 - 10:48 UTC

Investigating

We are currently investigating an issue with Cyber mainnet. The network is stalled at block 29,896,269.
All Cyber mainnet RPC endpoints are currently affected. New blocks are not being produced until the network resumes.
Our engineering team is actively investigating and working to resolve this issue. We will provide the next update by 11am UTC or sooner.
Posted Mar 11, 2026 - 09:51 UTC
This incident affected: Cyber (Mainnet - JSON-RPC API, Mainnet - Websockets API, Mainnet — Streams, Mainnet — Webhooks).