Sui Mainnet - Archive Degraded Performance

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 20:03 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 31, 2026 - 18:07 UTC

Investigating

The Quicknode team is investigating the degraded performance of Sui Mainnet archive nodes - we will update this page as we acquire new information.
Posted Jul 31, 2026 - 17:53 UTC
This incident affected: Sui (SUI Mainnet — gRPC / JSON-RPC API, Sui Mainnet - gRPC, Sui Mainnet - GraphQL).