Solana Mainnet : Degraded Performance

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 05:38 UTC

Monitoring

As of 03:45 UTC, services have been fully restored and are operating normally. Our engineers will continue to monitor the node infrastructure, and we will share the next update on or before 6.00 UTC.
Posted Sep 10, 2025 - 04:00 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 10, 2025 - 03:45 UTC

Investigating

We are investigating the degraded performance issue on the Solana mainnet, which may intermittently cause 503 errors.
As we progress toward a resolution, expect the next update on or before 5:00 UTC.
Posted Sep 10, 2025 - 03:30 UTC
This incident affected: Solana (Mainnet — JSON-RPC API, Mainnet — Websockets API).