Flow testnet - Network-wide Stall

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Feb 12, 2026 - 21:41 UTC

Investigating

We are currently experiencing a network-wide stall on Flow testnet at block 94,601,480 Customers will be unable to query new blocks or submit transactions until the network resumes block production. This is an upstream issue affecting the entire Flow testnet.
Posted Feb 12, 2026 - 02:58 UTC
This incident affected: Flow (Testnet — REST API, Testnet — Webhooks, Testnet — Streams).