zkSync Emergency Upgrade in Progress

Incident Report for QuickNode

Resolved

The emergency upgrade (v29.1.2) for zkSync has been successfully completed. Everything is now stable and operating normally.

We appreciate your patience and understanding while we worked with the foundation to complete this upgrade.
Posted Aug 27, 2025 - 17:11 UTC

Identified

We are currently performing an emergency upgrade (v29.1.2) to ensure the stability and security of the zkSync network.
We are working with the foundation to get this resolved.

During this process, some users may experience HTTP 503 errors.
These errors are expected and will occur intermittently.
Posted Aug 27, 2025 - 16:21 UTC
This incident affected: ZkSync Era (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — QuickAlerts, Mainnet — Streams).