Polygon Amoy — Degraded Performance on Archive Nodes

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jun 06, 2026 - 00:41 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2026 - 23:16 UTC

Identified

The issue has been identified and our engineering team is applying a fix.
Posted Jun 05, 2026 - 20:08 UTC

Investigating

The Quicknode team is investigating degraded performance on Polygon Amoy archive nodes — we will update this page as we acquire new information.
Posted Jun 05, 2026 - 14:33 UTC
This incident affected: Polygon (Amoy — JSON-RPC API, Amoy — Websockets API, Amoy — Webhooks, Amoy — Streams).