Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 22, 2026 - 22:30 UTC
Scheduled
We are upgrading our Sui Mainnet infrastructure to v1.70.2. During the maintenance window, brief interruptions to RPC availability may occur. This release introduces protocol version 121 with new protocol features.
gRPC #26070: When 0x1::type_name::TypeName Move values show up in structured outputs, it will show up as a simple string representation of the type, rather than an object with a name field.
#26062: Display v2: Implicitly format fields using the json transform, if the str transform would not work for them.
JSON-RPC #26070: When 0x1::type_name::TypeName Move values show up in structured outputs, it will show up as a simple string representation of the type, rather than an object with a name field.
#26062: Display v2: Implicitly format fields using the json transform, if the str transform would not work for them.
GraphQL #26061: Bugfix in how GraphQL fetches Display v2 formats
#26070: When 0x1::type_name::TypeName Move values show up in structured outputs, it will show up as a simple string representation of the type, rather than an object with a name field.
#26062: Display v2: Implicitly format fields using the json transform, if the str transform would not work for them.
Posted Apr 22, 2026 - 22:24 UTC
This scheduled maintenance affected: Sui (SUI Mainnet — JSON-RPC API, Sui Mainnet - gRPC, Sui Mainnet - GraphQL).