Quicknode Dashboard - Degraded Performance

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted May 20, 2026 - 14:04 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2026 - 14:02 UTC

Investigating

We are investigating the degraded performance of the Quicknode dashboard. Users may have issues accessing the Dashboard page at this time. We will update this page as we acquire more information.
Posted May 20, 2026 - 13:27 UTC
This incident affected: QuickNode Dashboard.