Near Mainnet: Archive Data Unavailable Before Block 158817115

Incident Report for QuickNode

Update

We're currently experiencing an issue where historical archive data for blocks prior to 158817115 before August 8th, 2025 at 23:59 UTC are unavailable, returning HTTP 422 "UNKNOWN_BLOCK" errors.

Our engineering team is working with the Near foundation team on restoring of blocks prior to 158817115 with a snapshot. Expected duration minimum of five days, expect the next update on Aug 29 at 17:00 UTC as we progress toward a resolution.
Posted Aug 25, 2025 - 18:44 UTC

Identified

We're currently experiencing an issue where historical archive data for blocks prior to 158817115 before August 8th, 2025 at 23:59 UTC are unavailable, returning HTTP 422 "UNKNOWN_BLOCK" errors.

Our engineering team is working with the Near foundation team on restoring of blocks prior to 158817115 with a snapshot. Expected duration minimum of five days, expect the next update on Aug 25 at 17:00 UTC as we progress toward a resolution.
Posted Aug 18, 2025 - 16:05 UTC
This incident affects: NEAR (Mainnet — JSON-RPC API).