Investigating | Dashboard, Streams & KV Store REST API

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Apr 12, 2026 - 16:19 UTC

Monitoring

The issue intermittently affecting the QuickNode Dashboard, Streams, and KV Store REST API has been resolved. Services have recovered and are operating normally. Our team will continue to monitor the situation closely to ensure stability is maintained. We apologize for any inconvenience this may have caused.
Posted Apr 12, 2026 - 09:45 UTC

Investigating

We are currently investigating an issue intermittently affecting the QuickNode Dashboard, Streams, and KV Store REST API. Some customers may experience degraded performance or errors. Our team is actively working to identify the root cause. We will provide updates as more information becomes available.
Posted Apr 12, 2026 - 08:55 UTC
This incident affected: QuickNode Dashboard.