Stuck Network - Hedera Testnet

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Aug 24, 2025 - 05:15 UTC

Monitoring

Following a Hedera Testnet network-wide stall, we have applied a fix to our Hedera Testnet nodes.

QuickNode has upgraded Hedera Testnet nodes to the latest release. Blocks are progressing again, and services are functioning normally. We are monitoring node performance to confirm stability. Full functionality is expected to be restored shortly.

Next update: 05:30 UTC, or sooner.
Posted Aug 24, 2025 - 05:00 UTC

Identified

The Hedera Foundation has confirmed a fix and will soon release a new version. QuickNode will upgrade nodes as soon as it is available.

Next update: 05:00 UTC, or sooner.
Posted Aug 24, 2025 - 03:45 UTC

Investigating

The Hedera Testnet appears to have stalled at block 23,978,370, which affects all QuickNode Hedera Testnet endpoints. As a result, API calls will return stale data reflecting the last processed block, and new blocks are not being produced.

QuickNode is investigating the cause with the Hedera Foundation.

Next update: 04:30 UTC, or sooner.
Posted Aug 24, 2025 - 02:31 UTC
This incident affected: Hedera (Testnet - JSON-RPC API, Testnet - REST API).