Robinhood Mainnet - 503 Errors on Archive Requests

Incident Report for Quicknode

Resolved

The 503 errors affecting Robinhood Mainnet archive nodes have been resolved.
Posted Jul 18, 2026 - 18:06 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2026 - 13:41 UTC

Investigating

We are investigating an issue with Robinhood Mainnet where archive requests are returning 503 errors. Our team is actively looking into the cause and will provide updates as more information becomes available.
Posted Jul 18, 2026 - 12:00 UTC
This incident affected: RobinHood (RobinHood - Mainnet - JSON RPC, RobinHood - Mainnet - Websocket).