Degraded Performance - BTC mainnet

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 04:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2025 - 03:12 UTC

Investigating

We are currently investigating this issue.
Posted Mar 25, 2025 - 02:50 UTC
This incident affected: Bitcoin (Mainnet — JSON-RPC API, Mainnet — Blockbook RPC Add-On).