Matic Amoy - block height stalled at 23238363

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 10:14 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 27, 2025 - 09:28 UTC

Investigating

We detected a network-wide stall on the Matic Amoy network: all Bor nodes halted at block height 23,238,363. We are actively investigating the root cause and have begun implementing an alternative solution to restore block production as quickly as possible. Please stay tuned for further updates.
Posted Jun 27, 2025 - 09:04 UTC
This incident affected: Polygon (Amoy — JSON-RPC API, Amoy — Websockets API, Amoy — QuickAlerts, Amoy — Streams).