Stuck Network - Celestia Mocha Testnet

Incident Report for QuickNode

Update

The network remains stalled, and our engineers are closely listening to updates from the foundation.

https://status.celestia.org/incidents/01K95G5PBBQGE5JHPCNAVFR5PM
Posted Nov 04, 2025 - 00:58 UTC

Investigating

The Celestia Mocha Testnet appears to have stalled at block 8687672- The QuickNode team is working with the chain team and will update with more information once it is available.

We will update this status by 00:00 UTC
Posted Nov 03, 2025 - 20:31 UTC
This incident affects: Celestia (Mocha Testnet — Tendermint JSON-RPC/REST API).