Scheduled: Maintenance – Solana Testnet

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 20:04 UTC

Investigating

The Solana Testnet will undergo scheduled maintenance on July 2, 2025, at 15:00 UTC as part of a coordinated halt and restart drill led by the validator team. This is a planned disruption to simulate cluster recovery procedures. During this time, users may experience delayed data and 503 errors. The network will be restarted shortly after the halt, and updates will be provided as progress continues.
Posted Jul 01, 2025 - 19:58 UTC
This incident affected: Solana (Testnet — JSON-RPC API, Testnet — Websockets API).