Degraded Performance - WorldChain Mainnet

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Sep 08, 2025 - 18:37 UTC

Identified

We are investigating degraded performance on our Worldchain Mainnet nodes.
Our nodes are currently lagging mainnet by ~300 blocks, which may cause slower responses or intermittent failures.

Action needed: No customer action is required at this time. We continue to work toward a solution with the chain team.

Next update: We will provide an update by 19:00 UTC or sooner if more information becomes available.
Posted Sep 08, 2025 - 16:56 UTC
This incident affected: World Chain (Mainnet — JSON-RPC API, Mainnet — Websockets API).