Blast Sepolia Network Stalled

Incident Report for Quicknode

Resolved

The incident has been resolved.
Posted May 14, 2026 - 16:35 UTC

Update

A fix has been applied to the Blast Sepolia network. We are monitoring for continued stability and will provide further updates as needed.
Posted May 14, 2026 - 16:33 UTC

Monitoring

A fix has been applied to the Blast Sepolia network. We are monitoring the network for continued stability.
Posted May 14, 2026 - 16:31 UTC

Investigating

The Blast Sepolia network appears to have stalled — The QuickNode team is investigating and will update with more information once it is available.
Posted May 14, 2026 - 16:30 UTC
This incident affected: Blast (Sepolia — JSON-RPC API, Sepolia — WebSocket API, Sepolia — Webhooks, Sepolia — Streams).