Solana Mainnet - Intermittent 503 Errors

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Aug 08, 2026 - 16:49 UTC

Monitoring

The intermittent 503s on Solana Mainnet have resolved. The AMS, FRA, SIN, and NRT regions observed the intermittent 503s. We are monitoring for stability.
Posted Aug 08, 2026 - 14:35 UTC

Investigating

The Quicknode team is investigating the degraded performance of Solana Mainnet - we will update this page as we acquire new information.
Posted Aug 08, 2026 - 14:14 UTC
This incident affected: Solana (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Streams, Mainnet — Webhooks).