Plasma Testnet Chain Halt

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 00:00 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 23, 2026 - 23:22 UTC

Investigating

Plasma testnet appears to have stalled at block 16,074,334 - The QuickNode team is investigating and will update with more information once it is available.
Posted Feb 23, 2026 - 23:04 UTC
This incident affected: Plasma (Testnet - JSON-RPC API, Testnet - Websockets API, Testnet — Streams, Testnet — Webhooks).