Polygon Amoy — Archive Requests Returning 503 Errors

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted May 19, 2026 - 16:06 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 19, 2026 - 15:14 UTC

Investigating

We are investigating an issue affecting Polygon Amoy archive nodes. Users may experience 503 errors when making archive requests. Our team is actively working to restore full service and will provide updates as more information becomes available.
Posted May 19, 2026 - 14:13 UTC
This incident affected: Polygon (Amoy — JSON-RPC API, Amoy — Websockets API, Amoy — Webhooks, Amoy — Streams).