Degraded Performance - Multiple chains experiencing network timeouts
Incident Report for QuickNode
Resolved
This incident has been resolved.
Posted Dec 17, 2024 - 00:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 16, 2024 - 23:44 UTC
Update
We are continuing to investigate this issue.
Posted Dec 16, 2024 - 20:36 UTC
Update
We are continuing to investigate this issue.
Posted Dec 16, 2024 - 20:29 UTC
Investigating
The QuickNode team is investigating the degraded performance causing timeouts on multiple chains - we will update this page as we acquire new information.

Networks affected:
Blast - mainnet
Bitcoin (btc) - mainnet
Celo - mainnet
Ethereum - mainnet and holesky
Hedera - mainnet
Ink - sepolia
Mantle - mainnet
Polkadot (dot) - mainnet
Scroll - mainnet
Solana (sol) - mainnet
Stacks (stx) - mainnet and testnet
Tron (tron) - mainnet
Posted Dec 16, 2024 - 20:13 UTC
This incident affected: Ethereum (Mainnet — JSON-RPC API, Mainnet — Websockets API, Holesky — JSON-RPC API, Holesky — Websockets API), Bitcoin (Mainnet — JSON-RPC API, Mainnet — Blockbook RPC Add-On), Solana (Mainnet — JSON-RPC API, Mainnet — Websockets API), Stacks (Mainnet — REST API, Mainnet — Websockets API), Polkadot (Mainnet - JSON RPC API, Mainnet - Websockets API, Mainnet - substrate-api-sidecar), Tron (Mainnet — JSON-RPC API, Mainnet — REST API), Scroll (Mainnet — JSON-RPC API, Mainnet — Websockets API), Blast (Mainnet — JSON-RPC API, Mainnet — Websockets API), Mantle (Mainnet — JSON-RPC API, Mainnet — Websockets API), Ink (Beta) (Sepolia — JSON-RPC API, Sepolia — Websockets API), and Celo (Mainnet — JSON-RPC API, Mainnet — Websockets API).