Solana Mainnet - gRPC Degraded Performance

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Mar 15, 2026 - 18:23 UTC

Investigating

The Quicknode team is investigating the degraded performance of the gRPC API on Solana Mainnet affecting all regions - we will update this page as we acquire new information.

Users may experience 503 errors, and timeouts during this time.
Posted Mar 12, 2026 - 17:23 UTC
This incident affected: Solana (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Streams, Mainnet — Webhooks).