Hyperliquid Testnet Network Stalled

Incident Report for Quicknode

Resolved

This incident has been resolved. Hyperliquid Testnet is operating normally.
Posted Aug 04, 2026 - 11:36 UTC

Investigating

We've identified this as an upstream issue with Hyperliquid Testnet and are waiting on a fix from the Hyperliquid team. We'll update this page as soon as we have more information.
Posted Aug 04, 2026 - 10:19 UTC
This incident affected: HyperLiquid (HyperEVM-Testnet - JSON-RPC API).