Hyperliquid EVM Testnet, Service Disruption

Incident Report for Quicknode

Resolved

This incident has been resolved. Block production on Hyperliquid's testnet network has resumed and service is back to normal.
Posted Aug 17, 2026 - 11:18 UTC

Investigating

We've identified an outage affecting Hyperliquid EVM Testnet. The root cause is an upstream stall on Hyperliquid's testnet network infrastructure, unrelated to QuickNode services. Users may experience failed or timed-out RPC requests until the upstream network resumes. We will continue monitoring and provide updates as they become available.
Posted Aug 17, 2026 - 10:40 UTC
This incident affected: HyperLiquid (HyperEVM-Testnet - JSON-RPC API).