Polygon zkEVM Mainnet - Block Height Stalled

Incident Report for Quicknode

Monitoring

Our engineers identified and addressed an issue affecting block height on Polygon zkEVM Mainnet endpoints. All systems are operating normally and we will continue to monitor to ensure stability.
Posted Jun 07, 2026 - 10:50 UTC

Investigating

We are currently investigating a block height stall affecting Polygon zkEVM Mainnet endpoints. We will provide updates as the investigation progresses.
Posted Jun 07, 2026 - 09:52 UTC
This incident affects: Polygon zkEVM (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Streams, Mainnet — Webhooks).