Injective Testnet Downtime - Required v1.18.1 Upgrade

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 16:22 UTC

Update

We are continuing to investigate this issue.
Posted Mar 02, 2026 - 16:22 UTC

Investigating

Injective Testnet nodes are currently undergoing a network upgrade to v1.18.1 at block height 115,505,000. This upgrade was recently released and is now being applied. During this process, testnet services may be temporarily unavailable. Our team is actively completing the upgrade and will provide updates as progress continues.
Posted Mar 02, 2026 - 16:19 UTC
This incident affected: Injective (Testnet Tendermint JSON-RPC/REST API, Testnet Cosmos gRPC & REST API, Testnet — Streams, Testnet — Webhooks).