[Standard] OP Stack - Mainnets & Testnets - Upgrade to op-reth v2.4.1 & op-node v1.19.4

Scheduled for Aug 17, 00:00 - 08:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 12, 2026 - 17:02 UTC

Scheduled

We are upgrading our OP Stack infrastructure to op-reth v2.4.1 and op-node v1.19.4 across Optimism, Unichain, Ink, Lisk, B3, Cyber, Mode, Zora, and Soneium mainnet and testnet.

This release includes transaction pool admission refinements, secure flashblocks endpoint fixes, and sequencer correctness improvements.

During the maintenance window, brief interruptions to RPC availability may occur.

RPC Changes:
eth_getBlockReceipts — This method is now forwarded to the historical endpoint for improved performance and compatibility.

https://github.com/ethereum-optimism/optimism/releases/tag/op-reth/v2.4.1
https://github.com/ethereum-optimism/optimism/releases/tag/op-node/v1.19.4
Posted Aug 12, 2026 - 16:43 UTC
This scheduled maintenance affects: Optimism (Mainnet — JSON-RPC API, Sepolia - JSON RPC), Cyber (Mainnet - JSON-RPC API, Sepolia — JSON-RPC API), Mode (Select Access) (Mainnet — JSON-RPC API), B3 (Mainnet — JSON-RPC API, Sepolia — JSON-RPC API), Ink (Beta) (Mainnet — JSON-RPC API, Sepolia — JSON-RPC API), Lisk (Select Access) (Mainnet — JSON-RPC API), Unichain (Beta) (Mainnet — JSON-RPC API, Sepolia — JSON-RPC API), and Soneium (Beta) (Mainnet — JSON-RPC API).