Blast-Sepolia: Blockheight Stall at #20155661

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 20:32 UTC

Identified

Posted Apr 18, 2025 - 18:03 UTC
This incident affected: Blast (Sepolia — JSON-RPC API, Sepolia — Websockets API).