Stuck Network - Hemi Testnet

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted May 18, 2025 - 21:26 UTC

Investigating

The Hemi Testnet appears to have stalled at block 3288527 - This is a Hemi Testnet blockchain issue, the Hemi team is aware and working to resolve the underlying issue.
Posted May 18, 2025 - 14:08 UTC
This incident affected: Hemi (Testnet - JSON-RPC API, Testnet — Websocket API).