BSC Testnet Degraded Performance for archive calls

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 19:23 UTC

Investigating

We are currently investigating this issue.
Posted Jun 11, 2025 - 13:01 UTC
This incident affected: BNB Smart Chain (BSC) (Testnet — JSON-RPC API, Testnet — Websockets API).