Stellar Mainnet: degraded performance

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 15:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2025 - 15:13 UTC

Investigating

We are currently experiencing instability with our Stellar mainnet Soroban nodes which may result in 503 errors for Soroban JSON RPC calls. Our engineering team is actively implementing mitigation measures to restore full service stability. We apologise for any inconvenience and will provide updates as the situation progresses.
Posted Mar 21, 2025 - 14:42 UTC
This incident affected: Stellar (Mainnet - REST API, Mainnet — JSON-RPC API).