Race Mainnet: Block stalled at 11096330

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 15:16 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 26, 2025 - 06:25 UTC

Investigating

We're seeing Race Mainnet stall at block 11096330. Our engineering team is investigating on this issue. We will provide updates as more information becomes available. We appreciate your patience during this brief interruption.
Posted Mar 22, 2025 - 13:37 UTC
This incident affected: RACE (Mainnet — JSON-RPC API, Mainnet — Websocket API).