Support Ticket-Form under Maintenance

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 19:09 UTC

Identified

We are currently working to improve our support ticketing system.
In the meantime, you can still reach us at Support@QuickNode.com.
Posted Apr 03, 2025 - 17:07 UTC
This incident affected: Customer Support.