Plasma Mainnet Degraded Performance - JFK Region

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 02:13 UTC

Update

We have identified the root cause of the degraded performance affecting Plasma Mainnet in the JFK region and node recovery is in progress.

As a temporary mitigation, traffic has been rerouted to nearby region while our engineers are working to recover the nodes. Some users may notice elevated latency at this time. We will continue to provide any new updates.
Posted Jun 04, 2026 - 23:00 UTC

Identified

We have identified the root cause of the degraded performance affecting Plasma Mainnet in the JFK region. Our engineers are actively working to restore the affected nodes.
Posted Jun 04, 2026 - 21:34 UTC

Investigating

The QuickNode team is investigating degraded performance of Plasma Mainnet nodes in the JFK region - we will update this page as we acquire new information.
Posted Jun 04, 2026 - 19:33 UTC
This incident affected: Plasma (Mainnet - JSON-RPC API, Mainnet - Websockets API, Mainnet — Webhooks, Mainnet — Streams).