Degraded Performance - Flow Mainnet

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 21:32 UTC

Investigating

We are working with the Flow Chain team to address some instability following today's upgrade.
FlowEVM is not yet available but should be back up soon. You may see 503s in the meantime.
Please follow https://status.flow.com/ for updates directly from the Flow team.

We will update this status by 23 UTC
Posted Oct 22, 2025 - 19:19 UTC
This incident affected: Flow (Mainnet — REST API, gRPC, Mainnet — Webhooks, Mainnet — Streams).