Degraded Performance - Monad Testnet

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 18:23 UTC

Investigating

The QuickNode team is investigating the degraded performance of Monad Testnet - we will update this page as we acquire new information.
Posted Apr 15, 2025 - 17:45 UTC
This incident affected: Monad (Monad Testnet).