Scroll Mainnet Emergency Patch v5.8.40

Incident Report for QuickNode

Resolved

We have successfully completed the deployment of the emergency patch (scroll-v5.8.40) on Scroll Mainnet.
More details: https://github.com/scroll-tech/go-ethereum/tree/scroll-v5.8.40
Posted Apr 25, 2025 - 22:42 UTC

Update

Intermittent service degradation (503s) may be expected over maintenance period
Posted Apr 25, 2025 - 20:52 UTC

Monitoring

We're currently deploying an emergency patch provided by the foundation to upgrade our system to scroll-v5.8.40 on mainnet. More details: https://github.com/scroll-tech/go-ethereum/tree/scroll-v5.8.40
Posted Apr 25, 2025 - 17:00 UTC
This incident affected: Scroll (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — QuickAlerts, Mainnet — Streams).