Morph mainnet : Block height stalled at 22013628

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 06:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2026 - 06:45 UTC

Identified

This is a chain-level incident.
As our engineers are actively monitoring updates from the Morph Foundation, please find the next update by 8 AM UTC.
Posted Apr 08, 2026 - 06:28 UTC

Investigating

We are currently investigating this issue.
Posted Apr 08, 2026 - 06:15 UTC
This incident affected: Morph (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Streams, Mainnet — Webhooks).