Injective Testnet - Block Stall at Height 97,319,182

Incident Report for QuickNode

Resolved

Block production on Injective Testnet has been fully restored. The Injective Foundation identified and resolved a peering issue that was preventing validators from communicating properly.
Posted Oct 21, 2025 - 09:48 UTC

Investigating

Block production has stalled on Injective Testnet at block 97,319,182. We are coordinating with the Injective Labs team to investigate the root cause. This is isolated to Testnet only and Injective Mainnet is unaffected.
Next update in 1h or sooner if status changes.
Posted Oct 21, 2025 - 09:37 UTC
This incident affected: Injective (Testnet Tendermint JSON-RPC/REST API, Testnet Cosmos gRPC & REST API, Testnet — Streams, Testnet — Webhooks).