Race Sepolia: Block Height Stalled at 16,006,377

Incident Report for QuickNode

Update

Race Sepolia network is currently experiencing a network-wide stall. We are actively monitoring the situation and awaiting instructions from Race Foundation before taking any remediation actions. ETA for resolution is pending their investigation and guidance.
Posted Jul 05, 2025 - 12:56 UTC

Investigating

We are currently investigating this issue.
Posted Jul 05, 2025 - 09:16 UTC
This incident affects: RACE (Sepolia — JSON-RPC API, Sepolia — Websocket API).