Degraded Performance - Injective Testnet

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted May 28, 2025 - 20:04 UTC

Investigating

The QuickNode team is investigating the degraded performance of Injective Testnet- we will update this page as we acquire new information.
Posted May 28, 2025 - 17:58 UTC
This incident affected: Injective (Testnet Tendermint JSON-RPC/REST API, Testnet Cosmos gRPC & REST API).