Stacks mainnet (STX) , Degraded Performance

Incident Report for Quicknode

Resolved

This incident has been resolved. Block production and network performance have returned to normal levels across all services.
Posted Aug 16, 2026 - 12:16 UTC

Identified

We identified what appears to have been an upstream issue on the Stacks network side that caused a temporary halt in block production. Block production has since resumed, and we are no longer observing degradation at this time. We will continue investigating and will share more information as it becomes available.
Posted Aug 16, 2026 - 11:27 UTC

Investigating

We are currently investigating a degradation affecting Stacks mainnet. Users may experience elevated response times and intermittent 503 errors. Our team is actively investigating and will provide updates as more information becomes available.
Posted Aug 16, 2026 - 11:05 UTC
This incident affected: Stacks (Mainnet — REST API, Mainnet — Websockets API).